
What to Expect in this Class 

Textbooks 
No required readings, most lesson books vary on focus topics so there is no “best” book 
just whatever suits the reader’s learning style. Reference books are handy for when you 
know what you want but have no idea how to achieve it. I have listed two below: 

• Macromedia Flash 8 Bible (Paperback)  
by Robert Reinhardt (Author), Snow Dowd (Author) 

• Macromedia Flash 8 On Demand (Paperback)  
by Andy Anderson (Author), Steve Johnson (Author) 

Online Resources 
These sites are great for finding tutorials and examples if you want to experiment on your 
own: 

• http://www.flashkit.com/ 
• http://www.w3schools.com 
• http://www.ActionScript.org 
• http://www.tutorialized.com 
• http://www.flashvault.net/ 

What is Flash? 
• Integrates video, text, audio, and graphics 
• Is consistent across platforms  
• Produces small files sizes 
• Can be viewed on any browser if Flash Player is installed 
• Viewed on more than 97% of Web-enabled computers world-wide 
• Is also accessible on mobile devices such as PDAs and cellphones 
• Used for things such as YouTube, web games that can also be played on the Wii 

(http://www.wiicade.com/), and animations such as for the Cartoon Network.  
• You can tell what things are made in Flash by right clicking on the object and the 

menu says “About Flash Player” 

Flash 8 professional vs Flash 8 basic, Mac vs Windows? 
• Flash 8 comes in 2 editions: Basic and Professional 
• Basic is a subset of Professional, which has more sophisticated interactive content, 

professional video settings, and the end results are easily deployed to devices 
• Flash is virtually the same on Mac and Windows, the only difference are some 

keyboard commands: Ctrl and Alt keys on the Windows, Command and Option 
keys on a Mac 

                                                                                                           
 



Introduction to Flash Work Flow 

Creating a Project Plan 
Before you jump into creating a movie, you need to create a project plan. The project 
plan is a site map, which allows you to pre-determine what elements you need ahead of 
time so you won’t waste time later redesigning your project. Follow these steps in 
planning your project: 

1) Determine the Purpose – By asking yourself, what is the reason for this project, 
you can narrow down what kind of interface you want. Is this a training video? Is 
this for entertainment? Questions like these allow you to focus on what type of 
navigational system you want to use such as buttons or pull down menus, to what 
designs you want to include, more flashy vs clean and simple.  

2) Identify the Audience – Who are you targeting? If this is a project for children, 
you do not want complex navigation and dull boring layout. 

3) Develop the Content and Organize the Structure – It’s scripting time. Like a 
play, this is when you want to list all the characters (elements) and the scenes. 
You can draw this out in a flow chart to help visualize navigation and how each 
section/scene is connected to each other. Make a chart of what each scene 
includes, such as text, graphics, audio, video, animations, navigation, and 
transitions. 

4) Develop the Layout and Design of the Movie – Now that you got the script, 
storyboard it. Storyboards help you visualize all the key points in the movie. 
Basically, all you are doing is sketching what you want each section to look like 
before actually jumping in and doing it. This saves a lot of time with layout 
during production.  

5) Identify the Requirements for Playback – You need to determine the minimum 
computer hardware and software that your viewers must have to view your 
product. Things to consider are CPU, RAM, sound cards, video cards, monitor 
resolution, internet connection speed, browser type and version. If your movie is 
graphic heavy, with a lot of animation going on, a viewer with dial-up and an 
older computer will have trouble running your movie.   

Building a Flash Project: The Six Main Steps 
1) Set up document properties - size of the stage and background color. This 

prevents having to redesign the movie later. 
2) Create or import media elements – which can be either static or dynamic. Static 

elements are text or graphics that are created or imported into the movie that do 
not change unless the author makes the change and then REPUBLISHES the 
movie. Dynamic elements are stored outside of the published movie and are 
loaded in by script. This method keeps updating easy and files sizes small. 

3) Position the media elements on Stage and sequence them in the Timeline – 
the stage represents the position in space (where) while the timeline represents the 
position in time (when) 

4) Add navigational components, interactive behaviors, and motion effects – 
time to do some coding. Flash has its own programming language called 
ActionScript. By using this language, you can add functionality, perform 



calculations, animate objects, or change the properties to an element. While you 
can write your own code from scratch, Flash has some built-in scripts called 
behaviors. It also has built-in elements called components, so you don’t need to 
create certain functionalities from scratch.  

5) Preview and test the movie – watch for animation inconsistencies and catch any 
script errors in the Output window.  

6) Publish the document – Produce the .swf and html files for uploading online. 

Document Types 
• Flash files, also called documents have a .fla extension 
• Published files for browsers have a .swf extension, which then get embedded in 

html files 
• Those are the 2 types that we will be using in this class. Other files types that Flash 

supports are:  
o ActionScript (.as) – stores ActionScript code for a Flash document 
o ActionScript Server (.asc) – stores ActionScript code on a computer with 

Flash Communication server 
o Flash Project (.flp) – files used to manage multiple documents in a single 

project 
o Javascript (.jsfl) – file with Javascript code to add additional functionality 
o Components (.swc) – contains reusable predefined graphic elements 

• These files involve intermediate to advance knowledge of coding, which won’t be 
covered in this class.  

Document Basics 

Creating/Opening Documents 
Can be done from the Start Page or under File>New. Once we open up a new document, 
we want to set up the document’s properties. This is done in the Document Properties by 
clicking Modify>Document, or by clicking the size button on the Properties panel.  
 

                                      
 
Here we set up the following, in which the values are for the entire document: 

• Title and Description – these allow online search engines to categorize your swf 
using metadata.  



• Dimensions – the size of your stage in pixels. Default is 550x400. Depending on 
your project, you will want to change this to what suits best. A recommended size 
for an all-Flash website is 800x600, which is a standard viewing size. 

• Match – this is for setting up your stage dimensions to match your maximum print 
area, equal space around your contents, or the default size.  

• Background Color – this color will be displayed all throughout the document. It 
will also be the background color used in the published html file. Unless you plan 
to use the same exact color throughout your document, it is recommended you 
leave it white, and just make your own backgrounds when needed. 

• Frame Rate – the number of frames per second for an animation to play. For 
most computers playing from the Web, 8 to 12 fps is adequate. The default is 12. 

• Ruler Units – units of measure used. Default is pixels, but if you need to measure 
content precisely to inches, change the setting to inches.  

Stage Size, Background Color and Frame Rate can also be changed directly in the 
Properties Panel. 

Multiple Documents Opened 
If you have several documents opened at once, Flash displays tabs right above the 
timeline. You can toggle between files by clicking on the tabs. Other viewing options can 
be found under Windows>Cascade and Windows>Tile. Cascade fits the windows one 
on top of the other with only the title bar showing, while Tile places them side by side.  

Saving Documents 
It is recommended that you save your files in versions as you work, in case of any 
computer errors or loss of power. And save regularly, especially after completing a major 
task. You can do quick saves by File>Save, which saves any new content to the existing 
file; or you can do File>Save As, which performs a complete save and compacts the file. 
Save As also allows you to rename the file as a different version, such as Project1, 
Project2, Project3 and so forth. If you should ever want to go back to the last saved point 
to “start over”, you can revert the document by going to File>Revert. 

Help While You Work 
If you get stuck on something, or need to find out how to use a command, Flash has its 
own built-in Help system. You can search for topics and keywords or use the table of 
contents to find what you need. To get to Help, go to menu Help>Flash Help. This will 
open up a dialogue box with content that is located on your hard drive. New additional 
content can be downloaded by clicking the Download Flash Help button on the panel. 
 
Another source of Help is the Flash Support Center, which takes you to the Flash support 
website. You need to have internet connection for this. To access this, go to Help>Flash 
Support Center.  

Closing Out 
When you are done with your document and have saved, you can just close the document 
or the program window. If you forgot to save, Flash will alert you and ask you if you 
want to save any changes.  



Working in the Flash Environment 

Main Toolbar 
• Is only in the Windows version of Flash 
• Like most of the buttons in Flash, positioning the cursor over the button gives you a 

tooltip label, displaying the button name 
• Contains the most used commands such as New, Open, Save, Print, Cut, Copy, 

Paste, Redo, Undo, Snap to Objects, Smooth, Straighten, Rotate/Skew, Scale, Align 
• The Undo command returns you to the previous point of action. Redo re-performs 

the command you undid. Flash supports up to 100 levels of undo and redo 
commands. 

Document Window: Edit Bar 
• Displays what mode you are working in, listing the scene first, followed by movie 

names 
• Contains button to hide and show the timeline 
• Contains a back button to take you back to the main stage 
• Contains pull down menus to switch scenes and modes 
• Allows you to zoom in and out of the stage with the pull down menu 

 
 

Document Window: Timeline 
The most complex panel of all panels. This is where everything takes place. The timeline 
organizes and controls elements in rows called channels and columns called frames. A 
frame represents a single point of time in the movie. It also consists of scenes and layers, 
which will be discussed later.  
 

 
 
The Status bar on the bottom of the Timeline, indicates the current frame, the document’s 
frames per second rate, and how much time has elapsed.  
 

 
 
You can change the size of the timeline area by dragging the bars surrounding it. You can 

also change the size of the frames by clicking the Frame View button   on Timeline, 
located right below the Edit Bar. Along with the size, you also have the option of viewing 
thumbnails in the frames with the Preview and Preview in Context modes.  



Document Window: Stage 
• Visible portion of the final movie 
• Provides a place to compose content for individual frames 
• Grey area around the stage, called the Pasteboard, can be used to store objects not 

in use at the time. These objects won’t show up on the screen but they do add to the 
file size.  

Property Inspector 
• View and change object attributes in this panel 
• Fields and buttons change depending on object selected 
• When no object is selected, default view is of document properties 

 

Panel Windows 
• Access to all authoring tools and attribute settings for elements 
• Located inside the right Docking Channel, a place to temporarily attach panels  
• The Docking Channels can be hidden to allow more work space 
• All panels include a header bar which shows the window title, the panel gripper, 

expander arrow, and an Options menu.  
• You can group and ungroup panels together by dragging them to the same panel 

window.  
• You can find all the panels under Window in the file menu bar.  

Tools Panel 
Also know as the Toolbar. Contains all the tools you need to create elements. You can 
drag the panel anywhere you want by clicking and dragging on the header bar. When 
drawing in Flash, the art you create is vector. Vector art is made up of mathematical 
values of lines and points to form objects, unlike bitmap art which is made up of dots per 
square inch. Since vector art is not limited to resolution, it can be scaled to any size 
without a loss of quality. In other words, the image does not become pixilated.  
 
There are two types of drawing models in Flash 8: Merge and Object drawing. Object 
drawing is new to Flash 8, while Merge drawing is the default style that Flash has always 
used. In Merge drawing, shapes combine into one when you overlap them, altering their 
form. In Object drawing, each shape or line you draw becomes its own object and 
overlapping them will not alter their form. An Object Drawing, when selected will 
display inside a blue bounding box. You can go between the two modes with a simple 
click of a button when you are using any of the drawing tools. This button will be located 
in the Options section of the tools panel.  



 
Selection 
Shortkey (V) 

Options: Snap to Objects, Smooth or 
Straighten a Selected Object  

 
Sub-Selection 
Shortkey (A) 

 
 

 
Free Transform 
Shortkey (Q) 

Options: Snap to Objects, Rotate and Skew, 
Scale, Distort, Envelope 

 

Gradient 
Transform 
Shortkey (F) 

Options:  Snap to Objects 

 
Line 
Shortkey (N) 

Options:  Object Drawing, Snap to Objects 

 
Lasso 
Shortkey (L) 

Options: Magic Wand, Magic Wand 
Settings, Polygon Mode 

 
Pen 
Shortkey (P) Options:  Object Drawing 

 
Text 
Shortkey (T)  

 
Oval 
Shortkey (O) Options:  Object Drawing, Snap to Objects 

 
Rectangle 
Shortkey (R) 

Options:  Object Drawing, Snap to Objects, 
Set Corner Radius 

 
Polystar 
 Options:  Object Drawing, Snap to Objects 

 
Pencil 
Shortkey (Y) 

Options: Object Drawing, Straighten Mode, 
Smooth Mode, Ink Mode 

 
Brush 
Shortkey (B) 

Options:  Object Drawing, Lock Fill, Brush 
Mode, Brush Size,  Brush Shape 

 
Ink Bottle 
Shortkey (S) 

 

 
Paint Bucket 
Shortkey (K) 

Options: Gap Size, Lock Fill 

 
Eyedropper 
Shortkey (I) 

 

 
Eraser 
Shortkey (E) 

Options: Eraser Mode, Faucet, Eraser Shape 

 
Hand 
Shortkey (H) 

 

Quick 
Overview 

of the 
Tools 
Panel 

 
  

Zoom 
Shortkey (M,Z) Options: Enlarge, Reduce 



 
Stroke Color – Strokes are the outlines of a 
vector object. 

 
Fill Color – A fill is a solid shape. It can be a 
color, gradient, texture, or bitmap. 

 
Black and White – When clicked, sets the 
Stroke to Black and the Fill to White. 

 
No color – Sets the Stroke or Fill to No 
color. 

Creating 
Colors 

  
Swap Colors – Exchanges the colors for 
Stroke and Fill. 

 

When you click on a color swatch, the color 
palette is revealed. The current color is 
displayed in the upper left corner, with its 
hexadecimal or RGB value shown to the 
right.  
 
The colors shown in the array of swatches 
are part of the Web 216 palette, which means 
that these colors can be displayed on any 
computer. If you create any new colors in the 
color mixer and then Save as a Swatch, the 
new swatch will be placed in between these 
and the gradient swatches. 
 
Below the solid colors, are default gradient 
swatches. When you create a new gradient 
swatch, it’ll be placed along side of these. 

 

This changes the Alpha (transparency) of a 
color. You can enter a number between 0 to 
100 or click and drag the bar to set a value. 
 

 
No color – Sets the Stroke or Fill to No 
color. 

 opens up     

Clicking this opens up the Colors dialogue 
box, where you can create custom colors. 
There are several options to view color 
selection: Color Wheel, Color Sliders, Color 
Palettes, Image Palettes, or Crayons. 
 



Creating Custom Colors 
You can also create colors not on the Web 216 palette by using the Color Mixer panel.  
 

                                             
 
By altering the RGB, Hue, Saturation, Brightness, and Alpha values, you can create a 
wide range of colors. Click the small triangles and drag the sliders, or type in the values 
for each value. You can also drag your cursor over the Color space bar at the bottom of 
the panel to change the color interactively. If you know the hexadecimal number of a 
color you want, you can type that in. 

Creating Gradients 
Gradients are made up of 2 or more colors that gradually fade into each other. There are 
two types of gradient modes in Flash: linear and radial. Linear gradients are made up of 
parallel bands of color. Radial gradients extend out from a single focal point. Both can 
be used on strokes or fills. You can add up to 16 colors in a gradient and control how they 
blend into each other. To create a gradient, go to the Color Mixer panel, then select 
Linear or Radial in the Type dropdown menu. Click on Overflow and select Extend, 
Reflect, or Repeat to control colors that extend past the gradient’s limits. Click anywhere 
on the gradient bar to make a new color proxy (little box with triangle on top). Double 
click on the proxy and a color palette will pop up. From there you can set the proxy to be 
any color you like. Do the same for all the proxies. Drag the proxies to change the color 
transition spans in the gradient bar. To delete a proxy, click and drag it down from the bar. 
It’ll disappear.  
 

                                           



Break Down of the Tools Panel 
Line Tool – Draws straight lines in any direction you drag your cursor. If you hold down 
the Shift key, the line will draw at a 45 degree angle. In Flash, a line is called a stroke and 
varies in thickness from 0 to 200 pixels. It can also vary in styles, colors, and have 
gradients. In Merge drawing, if you intersect two lines, the two lines become four 
segments, which can be altered separately. In the Properties panel, you can specify line 
caps and join types. A cap is the end point of a stroke that does not join with another 
stroke. A join is the point at which two strokes meet. You can also turn on stroke hinting, 
which adjusts line and curve anchors on full pixels to prevent blurring. 
 
Oval Tool – Creates ovals and circles. You can constrain proportions by holding down 
the Shift key. To create an oval with exact dimensions, hold the Alt (Win) or Option 
(Mac) button while clicking on the stage with the oval tool. A dialogue box will come up 
and you can specify the settings. Oval shapes are made up of strokes and fills. Strokes 
are the lines that surround and define the shape, the outline. Fills are the color or texture 
inside the shape. A shape can exist with only a stroke or a fill and not the other, but 
cannot exist without both.  
 
Rectangle Tool – Same as the oval tool, you can constrain proportions by holding Shift. 
Rectangles and squares are made of strokes and fills also. An extra option for the 
Rectangle tool is the Round Rectangle Radius button. By changing the point size from 0 
to 999, you can round the corners of the rectangle. Like the oval tool, holding Alt (Win) 
or Option (Mac) while clicking, will bring up a dialogue box for setting precise values. 
 
Polystar Tool – Works like the oval and rectangle tools, you can create polygons or stars 
with up to 32 sides. Located in the same spot as the rectangle tool, you can access this 
tool by clicking and holding on the rectangle tool button. In the Properties panel, you can 
set how many sides by clicking on the Options button. For stars, you have to set an 
additional value of point size, from .10 to 1.0 points. 
 
Selection Tool – Used to select objects as a whole or in parts. The selection tool can 
select just the stroke of an object, just the fill, or both. It can also select sections of an 
object. When you are positioning the cursor near a curve point, the cursor will display a 
little curve icon. When you are near a corner point, it displays a corner icon. By holding 
Shift, you can add additional elements to whatever ones you have already selected. 
Double clicking on a stroke will select all other strokes that are connected. Double 
clicking a fill will select it and all strokes that surround it. To select an object as a whole, 
you can click and drag a selection rectangle around the area. You can look at the Property 
panel to see information about what you have selected. It’ll show the stroke, fill, pixel 
dimensions, and x and y coordinates. You can also modify shapes with the Selection tool. 
Flash is the only vector program that allows you to change objects in a freeform manner 
by simply dragging the Selection arrow. You can convert line segments into corners by 
holding Alt (Win) or Option (Mac) while dragging.   
 



Lasso – Another selection tool, this one lets you draw around shapes for a more freeform 
selection. To make the selection with straight line segments, click the Polygon mode 
button in the Options area. 
 
Ink Bottle – Holds the properties for strokes that you set in any of the panels. You can 
click on any object on the Stage to change the stroke color, line weight and style. You 
can add a stroke to an object that doesn’t have one. To change an object’s stroke, click 
anywhere in the shape to change all strokes or on a single stroke to a particular side. 
 
Paint Bucket – Same way as how the Ink Bottle works, the paint bucket affects only the 
fill of any shape. You can add a fill to any shape that has a closed stroke. Change the 
sensitivity of the tool in the Options area to close up gaps. When applying a gradient with 
the paint bucket, you have the option of locking the location of the fill by clicking the Fill 
Lock button. This will lock the current gradient position of the object you are altering, so 
when you create another object with the same gradient, the gradient will flow 
continuously into the new object. If the Fill Lock button is off, the second object will 
have its own independent gradient fill. To add a gradient to several objects at once, select 
all the objects, and then click on them with the Paint bucket. 
 
Gradient Transform Tool – Used to change the size, rotation, width, or center of a 
gradient fill. For radial fills, you can adjust the focal point. When you position your 
cursor over the different handles, you can determine the functions by the icons your 
cursor displays: 

• Center point – four way arrow 
• Focal Point (radial fill only) – inverted triangle 
• Size – circle with an arrow 
• Rotation – four arrows in the shaped of a circle 
• Width – double-ended arrow 

Click and drag any of these handles to adjust the gradient. 
 
Eyedropper – Acts like a selection tool for stroke and fill properties. It picks up the 
settings from one object and allows you to transfer the same settings to another object. If 
you place the eyedropper over a stroke, the cursor changes to include a little pencil tool. 
Click on the stroke, and the cursor changes over to the ink bottle tool. Now it is ready to 
use the same stroke color, line weight and style on other objects. For fills, the cursor 
changes to include a tiny paintbrush. When you click on a fill, the cursor changes over to 
a paint bucket and is now ready to use on other objects.  
 
Pencil Tool – Used for freehand drawing. In the Options, you can set this to draw in 
Straighten, Smooth, or Ink mode. Smooth mode softens the curves of lines. You can 
change the smooth setting in the Properties panel from a range of 0 to 10. Straighten 
makes straight-line segments and standard curves. Flash performs shape recognition to 
the lines you draw and will convert your drawings into simple geometric shapes if it 
detects approximately that shape. If you want a completely freehand feel, Ink mode is 
probably the best way to go. Ink bypasses the shape recognition. One way to go about 
smoothing or straightening lines after drawing them is by selecting the line(s) with the 



Selection tool, then clicking the Smooth and Straighten options for the Selection tool. 
Another way is by optimizing the shape. To do this, select your object, then go to 
Modify>Shape>Optimize. There you can specify a smoothing level, use Multiple Passes, 
and show the reduction results when you are done. 
 
Brush Tool – Paints using fills. You can set the brush size, shape, and colors, along with 
locking the fill for gradients. In addition to those options, you are able to use five 
different modes:  

• Paint Normal – paints over everything including strokes and fills 
• Paint Fills – painting only affects existing fills and empty areas, strokes are not 

touched 
• Paint Behind – only paints in empty areas, existing lines and fills are not affected 
• Paint Selection – only paints within selected areas defined by a selection tool 
• Paint Inside – only affects the shape you started in, ignoring other shapes and 

empty areas on the stage 
 
Eraser Tool – Works like the Brush Tool but takes away fills and strokes instead of 
places them. Double clicking on the Eraser tool will delete everything on the Stage. 
Using the Faucet option allows you to click on a stroke or fill and delete it completely. 
This can also be achieved by selecting the objects, strokes, or fills you want and hitting 
the Delete key on the keyboard. Also like the Brush tool, the Eraser has different modes: 

• Erase Normal – erases strokes and fills on the same layer 
• Erase Fills – erases only fills; strokes are not affected 
• Erase Lines – erases only strokes; fills are not affected 
• Erase Selected Fills – erases only the currently selected fills and does not affect 

strokes, selected or not. (Select the fills you want to erase before using the Eraser 
tool in this mode.) 

• Erase Inside - erases only the fill on which you begin the eraser stroke. If you begin 
erasing from an empty point, nothing is erased. Strokes are unaffected by the eraser 
in this mode. 

 
Pen Tool – The most common form of drawing in vector programs such as Illustrator and 
Freehand. The Pen tool uses anchor points and Bezier handles to create lines and shapes. 
You can edit the anchor points and shapes using the key modifiers and Sub-Selection tool. 
To use this tool, click anywhere on the stage to begin. Move your cursor to another point 
and then click again. Flash will automatically connect the two points. If you click, hold, 
and drag your cursor, you are able to create curved lines. Repeat to make more points. To 
end a path, double-click the last point. If you want to create a closed path, bring the 
cursor back to the first point. When you see a small circle icon next to the pen, click the 
first point. To delete an anchor point with the Pen tool, select the shape. Your cursor icon 
should become a X. Position your cursor over the point you want to delete. When you see 
a small minus (–) sign, click the point. To create lines that are perfectly horizontal, 
vertical, or at a 45 degree angle, hold Shift while you draw. 
 
Sub-Selection Tool – There are two types of anchor points in vector drawing, Corner and 
Curve points. Corner points connect two line segments together at a sharp angle. Curve 



points define a curve or positions along a line. Curve points can be modified by Bezier 
handles. To modify an object’s points, click on the object with the Sub-Selection Tool. 
This will show you all the points in the object, displayed as little white squares around 
the edges. If you select one of the squares with the Sub-Selection Tool, the Bezier 
handles will appear. You can click and drag any of the handles, or the anchor point itself 
to alter the shape. To get a more precise location, use the arrow keys on your keyboard to 
move the selected anchor points. You can convert Curve points into Corner points by 
using the Pen tool and clicking on an anchor point. You can convert Corner points into 
Curve points by using the Sub-Selection tool, click a Corner point, and hold Alt (Win) or 
Option (Mac) while dragging the point.  
 
Free Transform Tool – Allows you to interactively scale or rotate any object on the 
Stage. When an object is selected, a bounding box will form around it. When you 
position your cursor near any of the black boxes, your cursor will display an icon for 
what function it is about to perform. When a double arrow icon is shown, click and drag 
any of the black boxes to resize the object. Corner boxes resize width and height, holding 
Shift while dragging will resize it proportionally. Boxes along the sides scale the object’s 
width or height. To rotate the object, position your cursor near a corner box, and when 
you see a partial circle icon, click and drag to rotate. Holding Shift rotates in 45 degree 
turns. To skew an object, position your cursor slightly above or below a side box, and 
when you see a parallel lines icon, you can click and drag to skew. If you want to control 
only one type of Transformation at a time, you can always click the Rotate/Skew or Scale 
buttons in the Options area. The other two options are used only for non-grouped shapes. 
The Distort tool allows you to distort the object with the corner boxes, and skew or 
stretch the shape with the side boxes. The Envelope tool works like Bezier curves and 
allows you to make more fluid changes. Every object has a Transformation Point, 
displayed as a white circle in the center of the object when selected. This point can be 
moved to affect your transformation. To move the point, click and drag it to a new spot. 
Double clicking it sets it back to the center. To see the X,Y position of the point, open up 
the Info panel and click on the center square in the grid. You can also use the Transform 
panel to perform precise degrees, or by using the commands under Modify. Two useful 
transformations that can only be found under the Modify menu are Flip Horizontal and 
Flip Vertical. You can undo any transformations on an object by going to 
Modify>Transform>Remove Transform. 
 
Zoom Tool – Used to magnify the stage. Click the + button in the Options area to zoom 
into the stage and the – button to zoom out. Flash allows you to view the stages at levels 
from 8% to 2000%. Click anywhere on the stage to zoom into that portion of the stage or 
click and drag to zoom into a defined area. You can also magnify the stage by using the 
pull down menu on the top right corner of the timeline. You can also type a specific value 
in the box.   
 
Hand Tool – Used to pan around the stage. When you are zoomed into the stage, parts of 
the stage may be off screen. To see these parts without having to zoom back out first, just 
used this tool to click and drag the stage until you can see the area you wanted. A quicker 



way to do this is to press and hold the Spacebar while dragging the cursor. Release the 
spacebar when you want to stop panning.  
 
Text Tool – There are three types of text in Flash: Static, Dynamic, and Input.  

• Static – used for displaying information or animation and does not change once the 
movie is published.  

• Dynamic – changes and updates even after the movie is published. It can display 
results from ActionScript or external files. 

• Input – textfields in which the user can type into, like a form or password box. 

 

Working with Static Text 
If you need a text box with a predefined width, you can create a text box before you start 
typing. Click on the stage with the Text tool and drag to draw out the size of the text box. 
You can go back and resize the box at any time by selecting it, and then dragging any of 
the black or blue resize handles, white circle for single line boxes, or white square for text 
blocks.  
 
A text box is active only when the background of the field is opaque white and text can 
be entered into it. If a text box is not active, you cannot change the content in it. But you 
can still change the font type, size, alignment and colors in the Properties panel.  
 

 
 
You can also adjust the tracking and kerning by changing the value in the box next to the 

character spacing entry . Tracking is the space between characters and words 
on a single line and adjusting it will affect the whole line. Kerning deals with the space 
between two characters and adjusting it will only affect that space. Most fonts have built-
in information about problematic character pairs, and Flash is able to space the characters 
properly using that information if you turn Auto-Kern on.  

Clicking on the  button gives you options to change the orientation and direction of 
the text. You can set the text to Horizontal, Vertical – Left to Right, or Vertical – Right to 
Left. When a vertical option is selected an additional rotate button will be displayed, 

. Click that to rotate your text. 
 
 
 



The Paragraph button  brings up a dialogue box that allows you to format the 
indentation of the first line, the leading (spacing between lines), and the left and right 
margins.   

                                
 

Use the font type  pull down to change the font from Normal to Subscript or 
Superscript.  
 
Anti-Alias Text is text that has been smoothed to blend into the background better. 
However at small font sizes, anti-aliased text is hard to read. Flash now has several 
settings for fonts to preserve their readability for different types of situations. Click the 
Anti-alias for animation pull down to change to the following settings: 

• Use device fonts – Uses fonts installed on the local computer 
• Bitmap Text (No Anti-Alias) – No text smoothing. 
• Anti-Alias for Animation – Smoothes out for animation 
• Anti-Alias for Readability – Uses anti-aliasing while making it readable 
• Custom Anti-Alias – Modify font properties, you set the values you want 
     - Sharpness – The smoothness of anti-aliasing transitions between text edges and   
       background 
     -Thickness – Thickness of font anti-aliasing transition 

Modifying Text as Art 
You can use broken apart text to create logos and designs. Once you have set up the text 
with the right font, size, and spacing, go to Modify>Break Apart. This will now break 
apart the whole line or word into individual letters. This makes it easier to rearrange 
individual letters. Select all the letters and break apart again to create vector shapes in 
which you can use the Envelope or Selection tool to alter the shapes of the text.  

Spell Checking 
Flash has a built in spell checker that is fully customizable. You can access this tool by 
going to Text>Spelling Setup. 
 
 
 
 
 
 
 



Timeline: Working with Layers  
Creating Layers 
Layers are like transparent sheets stacked on top of one another. You can edit objects on 
one layer without affecting objects on another layer. Only one layer can be active at a 
time, which is indicated by a pencil icon to the right of the layer name. You can select 
multiple layers at once by holding Shift or Ctrl (Cmd on a Mac). 

• To create a new layer, click the  button.  
• By default, layers are named based on the highest number. To rename the layer, 

double click the current name and type in a new name. 
• To rearrange layers, click and drag the layer up or down in the order.  
• When you have too many layers, they can be organized into layer folders. To create 

a layer folder, click . Rename it just like a regular layer.  
• To place a layer into a folder, click and drag the layer onto the folder layer. When 

released, the layer will position itself below the folder layer, slightly indented. To 
hide and show contents of the folder, click on the little triangle to the left of the 
folder name. 

• You can rearrange all the layers in a folder the same way as if they were outside a 
folder. When you move a folder layer, you are also moving all the layers inside it. 

• To delete a layer or folder, select it and click .  

• The  button creates a guide layer. Content in this type of layer does not get 
shown in the swf. These layers are used for hiding guide lines and other items that 
assisted in the creation process. Guide layers can also be used as motion guide 
layers, which we’ll discuss later in the animation section. 

 
Viewing Options in Layers 

• To hide or show a layer, click the dot in the  column. A red X should appear to 
indicate that the layer is now invisible. To hide all layers, click on the icon itself at 
the top of the timeline. This will turn all the layers invisible. When you hide a layer, 
it is only invisible in the authoring environment. When you publish the movie, any 
content in the hidden layer will still be viewable. 

• To lock a layer to prevent accidental editing, click the dot in the  column. A 
padlock will appear in place of the dot. As with the view icon, clicking the lock at 
the top will lock all layers. 

• To view the layer as outlines, click the dot in the  column. A frame will 
indicate if it is turned on or off. As with the other 2 tools, clicking the icon on top 
changes all layers. 

 
 
 
 
 
 
 



Layers Properties 
You can change a layer’s properties by going to Modify>Timeline>Layer Properties, 
or right clicking on the layer and selecting Properties in the menu. There you can set the 
following options: 

• Name – just like in the layer itself, you can change the name of it here. 

• Show – this is the same as using the  column. 

• Lock – this is the same as using the  column. 
• Type – these are the different types of layers you can have: Guide, Guided, Mask, 

Masked, and Folder. We will go into detail later about the guide and mask layers. 
• Outline color – determines what color objects on the stage will be displayed as 

when the  is checked. 

• View Layer as Outlines – same as clicking the  column. 
• Layer Height – use the pull down menu to determine how large you want the 

timeline info to be displayed at. 

Working with Graphics on Layers 
When you select an object, Flash also selects the Layer that it is on and makes it active. 
When you select a Layer to make it active, Flash selects all objects within that Layer. But 
a layer doesn’t have to be active for its objects to be edited. You can use the Paint Bucket 
tool on an object even if it is not selected. When you work with multiple players, be 
aware of which layer is active and lock any layers that are not in use.  

Copying and Pasting Between Layers 
Since Flash can only have one layer active at a time, modifying objects on different 
layers will require you to select the layers individually as you work. If you want to copy 
one object from Layer 1 into Layer 2, you would have to select Layer 2 before you paste 
the new object. To paste an object back in its original position, use Edit>Paste In Place. 
To paste the object on the center of the stage, use Edit>Paste In Center.  

Distributing Graphics to Layers 
If you have several objects on a single layer, and you want to put them on separate layers, 
select the objects and then go to Modify>Timeline>Distribute to Layers. This will 
place all shapes, groups, and symbols in their own layers. The order of the layers is 
determined by the order you originally place the objects on the stage. Any unselected 
objects will be left in the original layer. 
 
 
 
 
 
 



Creating Groups, Symbols, and Instances 
You can prevent unintentional edits to your objects by making them into groups or 
symbols. Groups are created on the Stage and are not stored anywhere else. Symbols are 
stored in the Library of your Flash document. Symbols are more efficient when building 
your movies because you can reuse these assets throughout your document and Flash 
would only have to store the information once. The Library stores all reusable objects 
such as symbols, sounds, video clips, bitmaps, and built-in Flash components.  

Creating a Group 
To create a group, select the objects you want, then go to Modify>Group. Once your 
objects are in a group, they cannot be edited unless you enter the group-editing mode. To 
do this, just double-click on the group. Up on the Edit bar, where it says Scene 1, it 
should now display that you are in a group. To ungroup an object, go to 
Modify>Ungroup, or Modify>Break Apart. When an object is grouped, it goes to the 
top of the stacking order within that layer. Any objects that are not grouped will always 
be displayed below grouped items. To rearrange the stacking order of groups, you can use 
the following commands under the Modify menu: 

• Bring To Front – the selected object is brought to the top of the stack 
• Bring Forward – the selected object is brought one level up in the stacking order 
• Send Backward – the selected object is brought down one level in the stack 
• Send To Back – the selected object is brought to the bottom of the stack  

Creating a Symbol 
When you create a symbol, it is stored in the Library. To make an object into a symbol, 
select the object, then go to Modify>Convert to Symbol, or press the F8 key. There are 
three default behaviors for symbols: Graphic Symbols, Movie Clips and Buttons. 
Depending on what you are using the symbol for, selected one of the behaviors. Then 
click on a point in the Registration grid as how you would like the object to be aligned to 
the symbol’s center point. If you haven’t drawn the object yet, you can make an empty 
symbol by Insert>New Symbol. Once you give it a name and a behavior, Flash 
automatically takes you into that symbol’s mode where you can draw your object.  
Here is a breakdown on what the three types of behaviors are: 

• Graphic – can be used for static images and for animations that are in sync with 
the main timeline. There are three instance options for graphic symbols: Loop, Play 
Once, and Single Frame. Unlike movie clips, animations can be seen without 
having to export a Flash movie. However, any sounds or ActionScript within a 
graphic symbol will not work in the authoring environment. 

• Movie Clip – operates independently from the main timeline. In order to see the 
animation, you need to export a Flash movie. Movie clips can have actions applied 
directly on them, and can be controlled by ActionScript.  

• Button – adds interactivity to the movie. The timeline inside a button is only 4 
frames long and defines the states of the button: up, over, down, and hit. We’ll get 
more into buttons in the Coding segment of Flash.  

 



Editing a Symbol 
Like a grouped object, in order to edit a symbol, you have to go into the symbol’s editing 
mode. You can do this several ways by double clicking on the symbol, or going up to 
Edit>Edit Symbol. You can also access any symbols by using the Symbols pulldown in 
the Edit Bar. Unlike grouped objects, symbols have their own discrete timeline. A 
grouped object has the same timeline as the scene that it resides in. A symbol has its own 
timeline and stage in its editing mode. When you edit a symbol in its own timeline, the 
changes are going to be stored in the Library and passed to all instances of the symbol. 
When you edit a group, the changes stay with that group only. Any copies of the group 
are not affected. To get out of editing mode, go to Edit>Edit Document or click on 
“Scene” in the Edit Bar. 

Using the Library 
All reusable assets are stored in the Library. This includes any objects made into symbols, 
imported bitmaps, sounds, video clips, and components. You can organize your assets 
into folders, duplicate symbols or change their behaviors. To access your Library, go to 
Window>Library. Flash has some pre-build libraries of symbols such as buttons. You 
can access the libraries by going to Window>Common Library and selecting the library 
type. All Library windows have a Preview area, where the selected symbol is displayed. 
You can view animations if a Play button is active in the Preview area. At the bottom of 
the Library, you’ll find the most commonly used command buttons, such as New Symbol, 
Add New Folder, Properties and Delete. You can access Library Options by clicking on 
the pull down in the top right corner. 

Creating an Instance of a Symbol 
To create an instance of a symbol, locate it in the Library. Select the item from the list, 
and drag the name on to the Stage. You can also drag the preview of the symbol to the 
Stage. Remember, this is a direct copy of what is in the Library. If you change anything 
within this instance’s editing mode, it will change the master symbol in the Library and 
all other instances in the document. However, you can change the outward appearance of 
this instance without altering the content inside. You can also change this instance’s 
behavior by going to the Properties panel and selecting a new Symbol Behavior. This is 
different from changing the behavior of a symbol in the Library panel, which changes it 
to the master symbol.  
 
If you want to make a new symbol that is slightly different from an existing one, you can 
duplicate the first symbol and then alter the new one. To duplicate a symbol, select it in 
the Library, then go up to the Options pull down and use Duplicate. Another way to do 
this if you already have an instance on the Stage is to select the instance, then click the 
Swap button in the Properties panel. A dialogue box will come up asking you if you want 
to swap it for another symbol. At the bottom of the box, there is a Duplicate Symbol 
button. Click that, give your new symbol a name, and hit Ok. The instance on the stage is 
now a copy of the new symbol in the Library.  



Breaking Apart Symbols 
To unlink an instance from the master symbol in the library, you have to break it apart. 
To do so, select the Object, go to Modify>Break Apart. You can also do this quickly by 
pressing Ctrl (Win)/ Cmd (Mac) + B.  

Modifying Instances 
While you cannot change the contents of an instance without affecting the master symbol 
in the Library, you can still modify the “shell” of an instance independently. You can use 
the Free Transform tool to scale, rotate, and skew the instance. You can use any of the 
Transform commands under the Modify menu. Most importantly, you can now use the 
Color Styles and Blends in the Properties panel. These options cannot be applied to 
ungrouped or grouped objects. They can only be used on symbols.  

Color Effects to Instances 
In the Properties panel, use the pull down menu next to Color to apply ONE of the 
following: 

• Brightness – enter a value from -100 to 100, or use the slider bar. -100 being black, 
100 being white 

• Tint – use the color box to choose a color. Enter a value between 0 and 100. (0 = 
no color, 100 = maximum saturation) 

• Alpha – enter a value between 0 and 100. (0 = invisible, 100 = fully visible) 
 
Since only one color effect can be applied to an instance, and if you wanted a 
combination of the above, you would have to use the advanced color option. 

• Advanced – this option allows you to change the percentage of red, green, and blue, 
along with the constant color and alpha values.  

Color Blends to Instances 
Since blend modes depend on the color of the instance you're applying the blend to and 
the underlying color, you must experiment with different colors and blends to get the 
results you want. The following blends are available in the Properties panel: 

• Normal - applies color normally, with no interaction with the base colors 
• Layer - lets you stack movie clips on top of each other without affecting their color 
• Darken - replaces only the areas that are lighter than the blend color. Areas darker 

than the blend color don't change. 
• Multiply - multiplies the base color by the blend color, resulting in darker colors 
• Lighten - replaces only pixels that are darker than the blend color. Areas lighter 

than the blend color don't change. 
• Screen - multiplies the inverse of the blend color by the base color, resulting in a 

bleaching effect 
• Overlay - multiplies or screens the colors, depending on the base colors 
• Hard light - multiplies or screens the colors, depending on the blend mode color. 

The effect is similar to shining a spotlight on the object. 
• Difference - subtracts either the blend color from the base color or the base color 

from the blend color, depending on which has the greater brightness value. The 
effect is similar to a color negative. 



• Invert - inverts the base color 
• Alpha - applies an alpha mask. Alpha blend mode requires that a Layer blend mode 

be applied to the parent movie clip. You cannot change the background clip to 
Alpha because the object would appear invisible. 

• Erase - removes all base color pixels, including those in the background image. 
Erase blend mode requires that a Layer blend mode be applied to the parent movie 
clip. You cannot change the background clip to Erase because the object would 
appear invisible. 

 

Displaying Rulers and Guides 
Rulers can be shown on the top and left sides of the stage to be used as guidelines. When 
the rulers are displayed, you can click and drag lines onto the stage from the rulers. These 
lines are used only in the editing environment and will not be in the final product. To 
access rulers, go to View>Rulers. You can modify the guides’ properties by going to 
View>Guides> Edit Guides. Another way of aligning elements properly is to use the 
grid. The grid can be turned on by going to View>Grid>Show Grid. You can modify the 
grid’s properties by going View>Grid>Edit Grid.  
 
A new feature in Flash 8 is the Snap Align, which enables dynamic alignment of objects 
on the Stage. When turned on, dashed lines will appear on the stage as you drag objects 
close to each other. This allows you to align the objects to each other’s sides and centers. 
To turn on Snap Align, go to View>Snapping>Snap Align. To change any settings, go 
to View>Snapping>Edit Snapping. 
 
 

Customizing Your Flash Workspace 
When you are feeling confident enough to navigate your way around the Flash 
environment, you may want to customize your panels and preferences.   
 
To set General, ActionScript, Auto Format, Clipboard, Drawing, Text, and Warning 
Preferences, go to Flash Professional on a Mac or Edit in Windows and click 
Preferences. 
 
To customize your Tools Panel, go to Flash Professional>Customize Tools Panel on a 
Mac or Edit>Customize Tools Panel in Windows.  
 
When you have your panels all laid out in the docking channels the way you like them, 
you can save your workspace by going to Window>Workspace Layout and clicking 
Save Current. Save it with any name. To access it, it’ll be located in 
Window>Workspace Layout. 
 
To create new keyboard shortcuts, go to Flash Professional>Keyboard Shortcuts on a 
Mac or Edit> Keyboard Shortcuts in Windows.  



Publishing a Movie 
When you are satisfied with your movie, it is time to publish it for distribution. You can 
access your publish settings by clicking the Publish settings button in your Properties 
Panel while in Document properties mode. You can also access them by going to 
File>Publish Settings.  
 

                                    
 
As you can see, there are several types of files you can publish as. If your project is going 
to be viewed online only, all you need to use are the Flash and HTML options. The other 
options include: 

• GIF image – saves out the currently selected frame. This format is primarily used 
for clipart, text, line art, and images that contain lots of solid colors. 

• Jpeg image – saves out the currently selected frame. This format is used mainly for 
photographic images.  

• PNG image – saves out the currently selected frame. This format is a hybrid format 
to save clip art, text, line art, and photographic images. 

• Windows and Mac Projectors – creates self-contained files that have Flash player 
built in. Since the player application is included, the final file size is increased to 
almost 1 MB. Projectors are best used on a hard drive or CD, and not for online 
viewing.  

• QuickTime – creates a quicktime movie, this is mainly for animations. 
 
Clicking the Use Default Names button creates the files using the same name as your 
document. To change your Flash and HTML settings, click the tabs at the top of the 
screen.  
 



                               
 
Version number – version of Flash player that is used to publish with. If you set it to 
anything earlier than Flash 8, some of your features may not work since they are only 
exclusive to Flash 8. 
Load order – the order of how layers load in the document. This is only noticed on really 
slow connections.  
ActionScript version – version of ActionScript to publish in. Publish with whatever you 
began your project in. Some commands are only available in ActionScript 2. If you 
attempt to publish in version 1 while using some of those commands, Flash will let you 
know to correct this.  
Generate Size report – creates a frame by frame size report for the active document 
Protect from Import – prevents the swf from being reopened in the Flash application 
Omit Trace Actions – prevents trace actions from being carried over. Trace is used for 
debugging ActionScript. 
Debugging Permitted – permits debugging of the Flash movie 
Compress Movie – compresses the movie for Flash 7 player only 
Optimize for Flash Player 6r65 – compresses for the Flash 6r65 player 
Password – enter a password for the document. This is used only if Protect from Import 
or Debugging Permitted was selected. 
Jpeg Quality – this sets the global compression for all bitmaps in the document 
Audio stream and event – audio settings for all imported sound files. These override the 
sound settings set individually in the document. Export device sounds creates audio 
suitable for mobile devices.  
Local playback security – change to allow Flash to access local or network resources. 
This is a security measure to prevent the swf from misusing external files. 
 



                                 
 
Template – select the type of Flash file you will be publishing as 
Detect Flash Version – this checks the version of Flash player that is installed on the 
viewer’s computer, and if it isn’t up to date, directs them to the Flash Update website. 
Dimensions – the size of your swf, in pixels or percentage 
Pause at Start – select this to pause your movie when loaded 
Loop – loops the movie 
Display Menu – allows a control menu to displayed when the swf is right-clicked on 
Device Font – use device fonts when needed 
Quality – varying from low (no anti-aliasing) to best (anti-alias everything) 
Window Mode –  

• Window - background of the Flash content is opaque and uses the HTML 
background color. HTML cannot render above or below the Flash content 

• Opaque Windowless - background of the Flash content is opaque, obscuring 
anything underneath the Flash content. HTML content appears above or on top of 
Flash content. 

• Transparent Windowless - background of the Flash content is transparent. HTML 
content to appear above and below the Flash content. 

HTML alignment – sets the alignment of the HTML page 
Scale – sets how the HTML will scale the swf when loaded. No Scale will keep the swf 
the same size, even if the browser window is resized. 
Flash alignment – how the swf is aligned in the page 
Show warning messages – display any warning messages 
 
 


